[ovs-dev] vSwitch OpenFlow re-write Ethernet address action support

Justin Pettit jpettit at nicira.com
Fri Oct 30 06:32:01 UTC 2009


On Oct 29, 2009, at 6:56 AM, Christian Esteve wrote:

> Using the same NOX component with OpenFlow 0.89rev2 underneath works  
> fine.

Are you using an application that ships with NOX or your own?

> Using vSwitch version 0.90.6  we get the errors we described:

As Ben noted, this should have been fixed in 0.90.6.  I built a custom  
NOX application to modify the Ethernet address, and it worked fine  
with Open vSwitch.  Can you double-check that you are using 0.90.6 and  
that it has the fix that Ben highlighted?

> With regard to trying to add the flows manually, we have not succeeded
> (yet), but most probably it is our fault. Note we tried with version
> 0.90.4 and not 0.90.6  as I indicated in my previous mail.
> See below our attempts. We are still confused on how the datapath
> control works in vSwitch. Is there somewhere to look at to better
> udnerstand the specific relationships between the different ovs
> modules and controllers?

Sections 3 and 4 of the following paper may help:

	http://openvswitch.org/papers/hotnets2009.pdf

I have a couple of presentations that I've been meaning to clean up  
and post, but I haven't had a chance yet.

> ./ovs-ofctl add-flow br0 in_port=1,udp,actions=mod_dl_dst: 
> 88:88:88:88:88:88,2
> modprobe: FATAL: Could not load /lib/modules/2.6.23/modules.dep: No
> such file or directory


That "br0" should be whatever you named your bridge in ovs- 
vswitchd.conf.

--Justin






More information about the dev mailing list