[ovs-dev] Removing "xs5.7" Branch?

Justin Pettit jpettit at nicira.com
Mon Apr 12 07:55:18 UTC 2010


Hey, Ian and Ben.  As you've probably noticed, I sent out some patches for things that were never transitioned from the "xs5.7" branch.  I've done my best to make it so that these changes work with XenServer 5.5 and 5.6, since OVS needs to support both.  

The only piece that appears to be missing is "fcc4950: Improve xsconsole plugin in various ways."  Everything from this commit should be brought over except the "xapi now takes care of syncing the setting to all hosts so no need to do that  manually" part.  Is this only true for 5.6, since "vswitch_controller" is a first class datamodel field?  For 5.5 should we still manually do the sync, since we use the "other_config" pool key?  If so, I guess I'll just leave the code and not execute it in 5.6.  Does this seem reasonable?

In the bring_down() function in InterfaceReconfigureVswitch.py, there's some commented out code regarding deconfiguring network-uuids.  Do we still need to actively do that?  We should either fix it or remove the code.

Once we get these things resolved, do you feel comfortable scrapping the "xs5.7" branch?  I'd appreciate you take a quick look to make sure I didn't miss anything.

Thanks!

--Justin






More information about the dev mailing list