[ovs-dev] [InBandOVSDB 4/4] vswitchd: Enable in-band control to managers.

Justin Pettit jpettit at nicira.com
Mon Apr 26 18:39:13 UTC 2010

On Apr 26, 2010, at 10:49 AM, Ben Pfaff wrote:

> On Mon, Apr 26, 2010 at 01:24:08AM -0700, Justin Pettit wrote:
>> On Apr 20, 2010, at 4:37 PM, Ben Pfaff wrote:
>>> static void bridge_reconfigure_controller(const struct ovsrec_open_vswitch *,
>>> -                                          struct bridge *);
>>> +                                          struct bridge *,
>>> +                                          const struct sockaddr_in *managers,
>>> +                                          size_t n_managers);
>> To be consistently vague, do you think we should rename this function
>> "bridge_reconfigure_controller"?
> Rename it to what?

"bridge_reconfigure_remotes".  It no longer is limited to just reconfiguring the controller.

>>> +/* Looks at the list of managers in 'ovs_cfg' and extracts their remote IP
>>> + * addresses and ports into '*managersp' and '*n_managersp'.  The caller is
>>> + * responsible for freeing '*managersp' (with free()).
>>> + *
>>> + * You may be asking yourself "WTF does ovs-vswitchd care?", because
>> :-) I've been trying to think how you can work more masked profanity
>> into our relatively dry mailing lists.  I know you're fond of saying
>> "patches accepted" when people get demandy of new features, but I just
>> came up with a new one you can try: "Bits or GTFO".
> I think the :-) means that you're joking, but just in case I changed the
> "WTF" to "Why".

Oh, I don't care.  I just thought it was funny since it was so incongruous.

I was joking about the GTFO comment, though.  Instead you should just send a big ASCII middle finger, and if they don't understand, deride them as newbies for not using MUTT and using non-monospaced fonts.


More information about the dev mailing list