[ovs-dev] ovs-appctl returns code 400

Ben Pfaff blp at nicira.com
Mon Nov 29 17:30:32 UTC 2010


On Mon, Nov 29, 2010 at 05:56:19AM -0800, xin zhang wrote:
>            I am not sure if I am in the right room, if this maillist
> is not for open vswitch user, pls kindly redirect me to correct place.

discuss at openvswitch.org is another list that you could use.  It is
probably a better choice.  But we might as well answer your questions as
long as they are here.

>            I just followed example in "How to Install Open vSwitch on
> Linux" to setup bridge "br0", now I want to list the bridge I create,
> brctl tool never works. 

That is an imprecise statement.  What did you do with brctl, what did
you expect to happen, and what actually happened?

> Then I use "ovs-appctl show br0" or "ovs-appctl show", the outputs
> just say: ovs-appctl: ovs-vswitchd: server returned reply code 400
>            what the magic code means? is any tips for me to get a
> readable print?

ovs-appctl is the wrong program for this purpose.  You should use
"ovs-dpctl show"  or "ovs-vsctl list-br" to list bridges.

(Does something in the documentation suggest that you should use
ovs-appctl for this?  If it does, then I would like to fix it.)

>            one more question, will open vswitch provide API for cloud
> software integrates itself with vswitch? I don't see any API doc. or
> it only provides a set of tools to easily play with vbridges?

I'll leave this question for others who are better suited to answer it.




More information about the dev mailing list