[ovs-dev] [python 00/31] Python fixes

Ben Pfaff blp at nicira.com
Tue Aug 23 21:04:54 UTC 2011


These fixes are based on Reid's review of the initial Python code
back in October:
http://openvswitch.org/pipermail/dev/2010-October/003927.html

Ben Pfaff (31):
  ovs.stream: Fix logic bug in Stream.connect().
  ovs.db.data: Fix bugs in Atom.is_default() and Datum.is_default().
  python: Use getattr() and setattr() instead of __dict__.
  python: Join a list of strings instead of concatenating a long
    string.
  python: Avoid lots of \" in quoted strings by using '' as outermost
    quotes.
  python: Take advantage of Python "x < y < z" syntax.
  python: Avoid using 'type' as a variable name.
  python: Avoid using 'tuple' as a variable name.
  daemon: Correct comment in Python implementation.
  daemon: Stylistic improvement for __read_pidfile in Python
    implementation.
  ovsdb-data: Simplify converting an OVSDB datum to JSON by reordering
    logic.
  ovs.db.idl: Improve error reporting for bad <row-update>s.
  ovs.db.idl: Actually use Idl.__modify_row()'s return value.
  ovs.db.idl: Use top-level class to represent IDL rows.
  ovs.db.parser: Simplify code.
  ovs.db.schema: Factor common checks for identifiers into new
    function.
  ovs.db.types: Use .append instead of += for adding to lists.
  ovs.db.types: Simplify code to avoid try/except case.
  ovs.db.types: Use toAtomicType() instead of open-coding it.
  ovs.db.types: Introduce DEFAULT_MIN, DEFAULT_MAX as Type class
    members.
  ovs.fatal_signal: Reorder definitions to be more easily readable.
  ovs.fatal_signal: Remove unnecessary "global" statement.
  ovs.json: Optimize __dump_string().
  ovs.jsonrpc: Remove dead class variable Message.__next_id.
  ovs.jsonrpc: Remove Connection.get_name()--clients can use 'name'
    directly.
  ovs.jsonrpc: Use "not X" in place of "len(X) == 0" for testing
    strings.
  ovs.reconnect: Make Reconnect.Reconnect inherit from object.
  ovs.reconnect: Fix typo in documentation.
  ovs.stream: Use %d in place of %ld since the two are equivalent in
    Python.
  ovs.stream: Drop Stream.get_name() since clients can use 'name'
    directly.
  ovs.stream: Simplify logic in Stream.wait().

 lib/ovsdb-data.c           |   18 ++++----
 lib/ovsdb-types.c          |    3 +-
 python/ovs/daemon.py       |   14 +++---
 python/ovs/db/data.py      |  105 ++++++++++++++++++++++----------------------
 python/ovs/db/error.py     |    4 +-
 python/ovs/db/idl.py       |   68 +++++++++++++++-------------
 python/ovs/db/parser.py    |   32 ++++++-------
 python/ovs/db/schema.py    |   24 +++++-----
 python/ovs/db/types.py     |   43 +++++++++---------
 python/ovs/fatal_signal.py |   28 +++++------
 python/ovs/json.py         |   10 +----
 python/ovs/jsonrpc.py      |   24 ++++------
 python/ovs/process.py      |    8 ++--
 python/ovs/reconnect.py    |   16 +++---
 python/ovs/stream.py       |   23 ++++-----
 15 files changed, 201 insertions(+), 219 deletions(-)

-- 
1.7.4.4




More information about the dev mailing list