[ovs-dev] [PATCH 1/3] util: Store version in global "program_version" string.

Ben Pfaff blp at nicira.com
Thu Aug 4 16:31:39 UTC 2011


On Thu, Aug 04, 2011 at 01:50:12AM -0700, Justin Pettit wrote:
> Useful in an upcoming commit.

Looks good, a few comments:

Please insert a line break between "void" and "set_program_name".  I
guess this style bug is very old.

You can delete the "if" test here, since free(NULL) is a no-op:
> +    if (program_version) {
> +        free(program_version);
> +    }

I think I'd rather have program_version be static and add a
get_program_version() accessor function.

For some reason the all-caps SET_PROGRAM_NAME bothers me.  Maybe the
macro could be set_program_name and the function behind it
set_program_name__()?  This would also require fewer changes to other
files.  But it is not important, if you don't like that idea.

Thanks,

Ben.



More information about the dev mailing list