[ovs-dev] [netlink v4 45/52] Eliminate ODPL_* from userspace-facing interface.

Justin Pettit jpettit at nicira.com
Wed Jan 26 09:36:52 UTC 2011


On Jan 11, 2011, at 9:49 PM, Ben Pfaff wrote:

> --- a/lib/dpif-linux.c
> +++ b/lib/dpif-linux.c
> @@ -775,7 +775,10 @@ parse_odp_upcall(struct ofpbuf *buf, struct dpif_upcall *upcall)
>     }
> 
>     memset(upcall, 0, sizeof *upcall);
> -    upcall->type = odp_upcall->type;
> +    upcall->type = (odp_upcall->type == _ODPL_MISS_NR ? DPIF_UC_MISS
> +                    : odp_upcall->type == _ODPL_ACTION_NR ? DPIF_UC_ACTION
> +                    : odp_upcall->type == _ODPL_SFLOW_NR ? DPIF_UC_SAMPLE

Is there a reason not to just rename _ODPL_SFLOW_NR to _ODPL_SAMPLE_NR for consistency?

Otherwise, looks good.

--Justin






More information about the dev mailing list