[ovs-dev] [PATCH 6/6] flow: Make IPv6 userspace code match kernel.

Ben Pfaff blp at nicira.com
Thu Mar 3 19:13:45 UTC 2011


On Wed, Mar 02, 2011 at 07:20:35PM -0800, Jesse Gross wrote:
> The flow extraction code for IPv6 has some deviations from both the
> kernel version and other protocols in userspace.  These differences
> make it difficult to compare the two for correctness.  This updates
> the code to be more similar to the others in design and style.  There
> is no functional change.

Two of the ofpbuf_try_pull() calls have a missing ! in the test.

In parse_icmpv6(), now that I've actually looked at struct
nd_neighbor_solicit, I question whether using it is actually helpful.
It's just an icmp6_hdr followed by an in6_addr.  We could just pull
the in6_addr ourselves and save the trouble of subtracting the length
of the icmp6_hdr.

Many pointers could be declared "const" in this code.

This changes a "return false" at the end of parse_icmpv6() to "return
true".  Isn't that a functional change?

There is duplicated code for IPPROTO_TCP and IPPROTO_UDP that we could
factor out.




More information about the dev mailing list