[ovs-dev] [timer 3/4] cfm: Use new timer library.

Ben Pfaff blp at nicira.com
Thu Mar 31 22:34:40 UTC 2011


This seems OK to me.  It changes the way things work a little bit, and
I didn't look at the big picture to make sure that it was equivalent.
I'll trust that you're confident that it's correct.

One little micro-detail caught my eye.  I now think that

            rmp->fault = rmp->fault || timer_expired_at(&cfmi->fault_timer,
                                                        rmp->recv_time);
            fault = rmp->fault || fault;

would be easier to read as:

	    if (timer_expired_at(&cfmi->fault_timer, rmp->recv_time)) {
                rmp->fault = true;
            }
	    if (rmp->fault) {
	        fault = true;
            }



More information about the dev mailing list