[ovs-dev] [sparc 3/5] in-band: Avoid "cast increases required alignment of target type" warning.

Justin Pettit jpettit at nicira.com
Thu May 26 08:55:26 UTC 2011


On May 24, 2011, at 11:21 AM, Ben Pfaff wrote:

> @@ -404,19 +404,18 @@ add_rule(struct in_band *ib, const struct cls_rule *rule)
> {
>     struct {
>         struct nx_action_set_queue nxsq;
> -        struct ofp_action_output oao;
> +        union ofp_action output;

I realize that we're only using the "output" member of the union, but the name is a bit confusing to me...especially when "output.output" is used.  What about something like "oa"?

--Justin





More information about the dev mailing list