[ovs-dev] [PATCH 1/2] datapath: Always notify in initial namespace for port deletions.
jesse at nicira.com
Mon Nov 21 18:16:01 UTC 2011
On Mon, Nov 21, 2011 at 10:09 AM, Ben Pfaff <blp at nicira.com> wrote:
> On Sat, Nov 19, 2011 at 02:40:13PM -0800, Jesse Gross wrote:
>> We currently notify for port deletions in the namespace of the device
>> that was deleted. In general this should be initial namespace because
>> that's the only place where we look but it's possible that the device
>> was moved after being attached. However, it's not semantically correct
>> because we really care about the namespace of the userspace process, not
>> that of the device. This switches to genl_multicast() which always uses
>> the initial namespace and seems more appropriate anyways.
>> Signed-off-by: Jesse Gross <jesse at nicira.com>
> s/genl_multicast/genlmsg_multicast/ in the commit message.
> I don't understand the primary explanation of this issue. What
> userspace process's namespace do we care about?
ovs-vswitchd, which will only be listening in the initial namespace
(at the moment but still a single namespace in the future). The
kernel should send all notifications to that namespace and it is not
related to where the devices are attached.
More information about the dev