[ovs-dev] [PATCH net-next 1/4] net: introduce skb_flow_dissect()

Dimitris Michailidis dm at chelsio.com
Mon Nov 28 16:25:39 UTC 2011


On 11/28/2011 07:22 AM, Eric Dumazet wrote:
> We use at least two flow dissectors in network stack, with known
> limitations and code duplication.
> 
> Introduce skb_flow_dissect() to factorize this, highly inspired from
> existing dissector from __skb_get_rxhash()
> 
> Note : We extensively use skb_header_pointer(), this permits us to not
> touch skb at all.
> 
> Signed-off-by: Eric Dumazet <eric.dumazet at gmail.com>
> ---
>  include/net/flow_keys.h   |   15 ++++
>  net/core/Makefile         |    2 
>  net/core/flow_dissector.c |  134 ++++++++++++++++++++++++++++++++++++
>  3 files changed, 150 insertions(+), 1 deletion(-)
> 
> diff --git a/include/net/flow_keys.h b/include/net/flow_keys.h
> new file mode 100644
> index 0000000..7a61e21
> --- /dev/null
> +++ b/include/net/flow_keys.h
> @@ -0,0 +1,15 @@
> +#ifndef _NET_FLOW_KEYS_H
> +#define _NET_FLOW_KEYS_H
> +
> +struct flow_keys {
> +	__be32 src;
> +	__be32 dst;
> +	union {
> +		__be32 ports;
> +		__be16 port16[2];
> +	};
> +	u8 ip_proto;
> +};
> +
> +extern bool skb_flow_dissect(const struct sk_buff *skb, struct flow_keys *flow);
> +#endif
> diff --git a/net/core/Makefile b/net/core/Makefile
> index 3606d40..c4ecc86 100644
> --- a/net/core/Makefile
> +++ b/net/core/Makefile
> @@ -3,7 +3,7 @@
>  #
>  
>  obj-y := sock.o request_sock.o skbuff.o iovec.o datagram.o stream.o scm.o \
> -	 gen_stats.o gen_estimator.o net_namespace.o secure_seq.o
> +	 gen_stats.o gen_estimator.o net_namespace.o secure_seq.o flow_dissector.o
>  
>  obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
>  
> diff --git a/net/core/flow_dissector.c b/net/core/flow_dissector.c
> new file mode 100644
> index 0000000..d0e085b
> --- /dev/null
> +++ b/net/core/flow_dissector.c
> @@ -0,0 +1,134 @@
> +#include <linux/skbuff.h>
> +#include <linux/ip.h>
> +#include <linux/ipv6.h>
> +#include <linux/if_vlan.h>
> +#include <net/ip.h>
> +#include <linux/if_tunnel.h>
> +#include <linux/if_pppox.h>
> +#include <linux/ppp_defs.h>
> +#include <net/flow_keys.h>
> +
> +
> +bool skb_flow_dissect(const struct sk_buff *skb, struct flow_keys *flow)
> +{
> +	int poff, nhoff = skb_network_offset(skb);
> +	u8 ip_proto;
> +	u16 proto = skb->protocol;

__be16 instead of u16 for proto?



More information about the dev mailing list