[ovs-dev] [mirror 00/13] improve mirroring implementation

Ben Pfaff blp at nicira.com
Wed Oct 26 17:09:33 UTC 2011


This series of patches essentially rewrites the OFPP_NORMAL
implementation, improving its performance and eliminating some
ofproto-dpif.c.  It's an intermediate step toward adding some
more mirroring features.

Ben Pfaff (13):
  ofproto-dpif: Do not output RSPAN packets to SPAN ports.
  ofproto-dpif: Remove duplicate VLAN logic.
  ofproto-dpif: Make compose_mirror_dsts() harder to screw up.
  ofproto-dpif: Improve RSPAN translation performance from O(n**2) to
    O(n).
  flow: Rename flow_compare() to flow_compare_3way().
  shash: New function shash_find_len().
  odp-util: Code formatting improvements.
  odp-util: New function ovs_key_attr_to_string().
  odp-util: New function factored out of put_userspace_action().
  odp-util: Add support for named ports to odp_flow_key_from_string().
  odp-util: New function odp_actions_from_string().
  tests: Rewrite code for comparing sets of ODP actions.
  ofproto-dpif: Get rid of "struct dst".

 lib/flow.h                   |    6 +-
 lib/odp-util.c               |  353 ++++++++++++++++++++++++++++--
 lib/odp-util.h               |   10 +-
 lib/shash.c                  |   25 ++-
 lib/shash.h                  |    3 +-
 ofproto/ofproto-dpif.c       |  495 ++++++++++++++++++------------------------
 tests/automake.mk            |    1 -
 tests/compare-odp-actions.pl |   66 ------
 tests/ofproto-dpif.at        |   18 +-
 tests/test-odp.c             |    2 +-
 utilities/ovs-dpctl.c        |  235 ++++++++++++++++++++
 vswitchd/vswitch.xml         |    1 +
 12 files changed, 833 insertions(+), 382 deletions(-)
 delete mode 100644 tests/compare-odp-actions.pl

-- 
1.7.2.5




More information about the dev mailing list