[ovs-dev] [PATCH 13/18] add minimal NetBSD support

YAMAMOTO Takashi yamamoto at valinux.co.jp
Fri Feb 1 02:35:26 UTC 2013


hi,

> On Thu, Jan 31, 2013 at 07:49:47PM +0900, YAMAMOTO Takashi wrote:
>> From: YAMAMOTO Takashi <yamt at mwd.biglobe.ne.jp>
>> 
>> mostly ride on the existing FreeBSD support.
>> 
>> Signed-off-by: YAMAMOTO Takashi <yamamoto at valinux.co.jp>
> 
> ...
> 
>> @@ -1458,6 +1485,13 @@ static int
>>  set_etheraddr(const char *netdev_name, int hwaddr_family,
>>                int hwaddr_len, const uint8_t mac[ETH_ADDR_LEN])
>>  {
>> +#if defined(__NetBSD__)
>> +    (void)netdev_name;
>> +    (void)hwaddr_family;
>> +    (void)hwaddr_len;
>> +    (void)mac;
>> +    return ENOTSUP; /* XXX */
> 
> OVS generally uses EOPNOTSUPP (not ENOTSUP, which I hadn't known about)
> internally to indicate that an operation isn't supported.  Will you
> change this instance to EOPNOTSUPP?  Thanks.

ok.

> 
>> -#ifdef __FreeBSD__
>> -#define FREE_BSD 1
>> +#if defined(__FreeBSD__) || defined(__NetBSD__)
>> +#define FREEBSD_OR_NETBSD 1
>>  #else
>> -#define FREE_BSD 0
>> +#define FREEBSD_OR_NETBSD 0
>>  #endif
> 
> It might be more readable to just use "BSD" in place of
> FREEBSD_OR_NETBSD, which is a bit long.

i hesitate to use "BSD" only for FreeBSD and NetBSD given that
there are too many BSD variants in the world.

probably a more meaningful name like REGISTER_TUNNEL is better
in the regard of readability?

YAMAMOTO Takashi

> 
> Thanks,
> 
> Ben.



More information about the dev mailing list