[ovs-dev] [test log scan v2 4/6] tests: Set explicit bond mode in LACP test.

Ethan Jackson ethan at nicira.com
Tue Feb 5 21:02:17 UTC 2013


This seems fine to me.  The default bond mode has been active-backup
for quite a while, so it may simply make sense to remove this warning
in the post 1.10 release.

Acked-by: Ethan Jackson <ethan at nicira.com>

On Fri, Feb 1, 2013 at 10:48 AM, Ben Pfaff <blp at nicira.com> wrote:
> This avoids a log warning:
>
>     bridge|WARN|port bond: Using the default bond_mode active-backup.
>     Note that in previous versions, the default bond_mode was balance-slb
>
> This warning is harmless, but I'm trying to add checks for "warn" and
> higher severity log messages to the tests, so it makes sense to get rid of
> this one.
>
> Signed-off-by: Ben Pfaff <blp at nicira.com>
> ---
>  tests/lacp.at |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/tests/lacp.at b/tests/lacp.at
> index 408b1ec..49f3bb1 100644
> --- a/tests/lacp.at
> +++ b/tests/lacp.at
> @@ -40,7 +40,7 @@ AT_CLEANUP
>  AT_SETUP([lacp - multi port config])
>  OVS_VSWITCHD_START([dnl
>          add-bond br0 bond p1 p2 --\
> -        set Port bond lacp=active \
> +        set Port bond lacp=active bond-mode=active-backup \
>              other_config:lacp-time="fast" \
>              other_config:lacp-system-id=11:22:33:44:55:66 \
>              other_config:lacp-system-priority=54321 --\
> --
> 1.7.2.5
>
> _______________________________________________
> dev mailing list
> dev at openvswitch.org
> http://openvswitch.org/mailman/listinfo/dev



More information about the dev mailing list