[ovs-dev] Bug#701760: openvswitch-switch: problem interacting with libvirt

Ernesto Domato edomat at gmail.com
Tue Feb 26 19:47:17 UTC 2013


Package: openvswitch-switch
Version: 1.4.2+git20120612-9
Severity: important

Hi, I'm using openvswitch with libvirt and it works as expected.

The problem that I'm having is that if you reboot or shutdown the host server,
openvswitch is going down before libvirt virual machines finish going down too.

The ovs-vsctl command gives the following error:

Feb 26 12:57:16 stephen ovs-vsctl: 00001|vsctl|INFO|Called as ovs-vsctl --
--if-exists del-port vnet0
Feb 26 12:57:16 stephen ovs-vsctl: 00002|stream_unix|ERR|/tmp/stream-
unix.32206.0: connection to /var/run/openvswitch/db.sock failed: No such file
or directory
Feb 26 12:57:16 stephen ovs-vsctl:
00003|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt
failed (No such file or directory)

and keeps reporting this for long period of time.

This is caused when libvirt tries to delete the virtual network interface from
the virtual openvswitch switch but it is not running anymore.

So, I have to restart the openvswitch by login remotely on the host machine
because at that point, console stop responding too, so the ovs-vsctl command
can finnish normaly and the box is halted or rebooted.

I don't know what should be the correct solution, but at least I think that
openvswtich should wait for libvirt to finish correctly before going down.

Thanks for all.
Ernesto



-- System Information:
Debian Release: 7.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=es_AR.UTF-8, LC_CTYPE=es_AR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages openvswitch-switch depends on:
ii  libc6               2.13-38
ii  libssl1.0.0         1.0.1e-1
ii  module-init-tools   9-2
ii  netbase             5.0
ii  openvswitch-common  1.4.2+git20120612-9
ii  procps              1:3.3.3-2
ii  python              2.7.3-4
ii  uuid-runtime        2.20.1-5.3

openvswitch-switch recommends no packages.

Versions of packages openvswitch-switch suggests:
pn  openvswitch-datapath-module  <none>

-- no debconf information



More information about the dev mailing list