[ovs-dev] [PATCH 13/18] add minimal NetBSD support

Ben Pfaff blp at nicira.com
Fri Feb 1 02:49:42 UTC 2013


On Fri, Feb 01, 2013 at 11:35:26AM +0900, YAMAMOTO Takashi wrote:
> >> -#ifdef __FreeBSD__
> >> -#define FREE_BSD 1
> >> +#if defined(__FreeBSD__) || defined(__NetBSD__)
> >> +#define FREEBSD_OR_NETBSD 1
> >>  #else
> >> -#define FREE_BSD 0
> >> +#define FREEBSD_OR_NETBSD 0
> >>  #endif
> > 
> > It might be more readable to just use "BSD" in place of
> > FREEBSD_OR_NETBSD, which is a bit long.
> 
> i hesitate to use "BSD" only for FreeBSD and NetBSD given that
> there are too many BSD variants in the world.
> 
> probably a more meaningful name like REGISTER_TUNNEL is better
> in the regard of readability?

OK, that seems reasonable, thanks.


More information about the dev mailing list