[ovs-dev] [ovs-discuss] How to specify the OF version in OVS?

Jing Ai ai_jing2000 at hotmail.com
Wed Jan 9 19:15:26 UTC 2013


Thanks for documenting it. It really helps.
I have one follow-up question. Is this command valid only in the master now? I just tried OVS 1.9 branch, ovs-vsctl does not understand "protocols".
ovs-vsctl list bridge_uuid               : 84b55699-399e-4cd4-8838-81270aa8600ccontroller          : []datapath_id         : "00009a56b584d44c"datapath_type       : ""external_ids        : {}fail_mode           : []flood_vlans         : []flow_tables         : {}mirrors             : []name                : "dp0"netflow             : []other_config        : {}ports               : [aab5d497-ce4e-4f11-93ca-21492019de7c]sflow               : []status              : {}stp_enable          : false
Therefore, does OVS 1.9 and previous version support all OF versions by default?

> Date: Mon, 7 Jan 2013 12:45:04 +0900
> From: yamahata at valinux.co.jp
> To: blp at nicira.com; dev at openvswitch.org
> CC: ai_jing2000 at hotmail.com; bugs at openvswitch.org
> Subject: Re: [ovs-discuss] How to specify the OF version in OVS?
> 
> On Thu, Jan 03, 2013 at 09:05:21AM -0800, Ben Pfaff wrote:
> > On Thu, Jan 03, 2013 at 06:52:30AM +0000, Jing Ai wrote:
> > > Therefore, my question is how to specify the OpenFlow version in
> > > ovs-vswitchd. I could not find any command-line flag from man
> > > page. Thanks!
> > 
> > See ovs-vswitchd.conf.db(5):
> > "ovs-vsctl set bridge <name> protocols=openflow10,openflow12,openflow13"
> 
> An example in ovs-vsctl.8 would help. I was asked what's the command line to 
> configure OF version.
> 
> 
> From 1e06d7a4dc75f2bbabca4f904747c6e3afab2923 Mon Sep 17 00:00:00 2001
> Message-Id: <1e06d7a4dc75f2bbabca4f904747c6e3afab2923.1357530055.git.yamahata at valinux.co.jp>
> In-Reply-To: <0639ad6e831c28768eceef30fc1325b30eddfa84.1357530055.git.yamahata at valinux.co.jp>
> References: <0639ad6e831c28768eceef30fc1325b30eddfa84.1357530055.git.yamahata at valinux.co.jp>
> From: Isaku Yamahata <yamahata at valinux.co.jp>
> Date: Mon, 7 Jan 2013 12:39:25 +0900
> Subject: [PATCH] ovs-vsctl.8: an example to configure openflow version
> 
> Signed-off-by: Isaku Yamahata <yamahata at valinux.co.jp>
> ---
>  utilities/ovs-vsctl.8.in |    6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/utilities/ovs-vsctl.8.in b/utilities/ovs-vsctl.8.in
> index e19340f..3886920 100644
> --- a/utilities/ovs-vsctl.8.in
> +++ b/utilities/ovs-vsctl.8.in
> @@ -911,6 +911,12 @@ Deconfigure STP from above:
>  .IP
>  .B "ovs\-vsctl clear Bridge br0 stp_enable"
>  .PP
> +.SS "OpenFlow Version"
> +.PP
> +Configure bridge br0 to use openflow version of 1.0, 1.2 and 1.3:
> +.IP
> +.B "ovs\-vsctl set bridge br0 protocols=openflow10,openflow12,openflow13"
> +.
>  .SH "EXIT STATUS"
>  .IP "0"
>  Successful program execution.
> -- 
> 1.7.10.4
> 
> 
> 
> -- 
> yamahata
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-dev/attachments/20130109/22ab5aa9/attachment-0003.html>


More information about the dev mailing list