[ovs-dev] [ext-260 v3 0/5] add support for OF1.2+ experimenter error codes

Ben Pfaff blp at nicira.com
Wed Jun 12 18:35:11 UTC 2013


This series adds support for OF1.2+ experimenter error codes.

v1->v2: Make it much easier to add new experimenter IDs and updates the
error code used to the one used in the latest version of the EXT-260
proposal, using an ONF experimenter ID.

v2->v3: Rebase against current master, repost to get into patchwork.

Ben Pfaff (5):
  ofp-errors: Fix typos in comment.
  ofp-errors: Make ofperr_decode() static.
  extract-ofp-errors: Remove support for hexadecimal error types.
  ofp-errors: Implement OpenFlow 1.2+ experimenter error codes.
  ofp-errors: New error code ONFBIC_DUP_INSTRUCTION.

 OPENFLOW-1.1+                      |    3 -
 build-aux/extract-ofp-errors       |  330 +++++++++++++++++++++---------------
 include/openflow/nicira-ext.h      |    1 -
 include/openflow/openflow-1.2.h    |    5 +-
 include/openflow/openflow-common.h |   25 +++-
 lib/automake.mk                    |    9 +-
 lib/ofp-actions.c                  |    4 +-
 lib/ofp-errors.c                   |   74 ++++++---
 lib/ofp-errors.h                   |   97 +++++++-----
 tests/ofp-actions.at               |    4 +-
 tests/ofp-errors.at                |   51 +++++-
 utilities/ovs-ofctl.c              |   15 +-
 12 files changed, 391 insertions(+), 227 deletions(-)

-- 
1.7.2.5




More information about the dev mailing list