[ovs-dev] [threads 02/11] ovs-thread: Add per-thread data support.
blp at nicira.com
Tue Jun 25 20:05:43 UTC 2013
On Tue, Jun 25, 2013 at 12:56:09PM -0700, Ethan Jackson wrote:
> I don't really like the names of the functions "NAME_get" and
> "NAME_get__" could we come up with something that's a bit more
> specific about the difference between them? Maybe get_init and get?
> I'm not sure what would be best . . .
The idea is supposed to be that you call NAME_get() by default, since
it's always safe, and NAME_get__() if you know what you're doing and
know that that is safe. How about, then, NAME_get() and
NAME_get_preinited() or NAME_get_unsafe() or ...?
> Acked-by: Ethan Jackson <ethan at nicira.com>
More information about the dev