[ovs-dev] Support for Linux 3.10

Jesse Gross jesse at nicira.com
Tue Jun 25 22:55:52 UTC 2013


On Fri, Jun 21, 2013 at 3:32 AM, James Page <james.page at ubuntu.com> wrote:
> Hi OpenvSwitch Devs
>
> Ubuntu Saucy is about to bump kernel version from 3.9 to 3.10; I started
> looking at the impact of this on ovs but swiftly went down the rabbit hole
> of not really understanding how the introduction of 802.1ad support in this
> kernel version would impact on the compat layer of ovs; specifically the
> following kernel commits:
>
> net: vlan: rename NETIF_F_HW_VLAN_* feature flags to NETIF_F_HW_VLAN_CTAG_*
>
> http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f646968f8f7c624587de729115d802372b9063dd
>
> net: vlan: add 802.1ad support
>
> http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8ad227ff89a7e6f05d07cd0acfd95ed3a24450ca
> http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=4ada8db38a44654446fe35ceb20a1972220e0f69
>
> net: vlan: add protocol argument to packet tagging functions
>
> http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=86a9bad3ab6b6f858fd4443b48738cabbb6d094c
>
> I was unsure as to whether this was suitable for inclusion in
> datapath/compat/* or whether the datapath module itself should have
> conditional code to deal with >= 3.10.0.

The compat directory is definitely the preferable location in general.
Are the specific areas/functions that you were thinking about that
might be a problem?



More information about the dev mailing list