[ovs-dev] [PATCH 2/2] datapath: Resolve external module dependencies.

Jesse Gross jesse at nicira.com
Fri Jun 28 00:25:18 UTC 2013


On Thu, Jun 27, 2013 at 12:29 AM, Rajahalme, Jarno (NSN - FI/Espoo)
<jarno.rajahalme at nsn.com> wrote:
>
> On Jun 26, 2013, at 21:39 , ext Jesse Gross wrote:
>>>
>>> OK, so you need to use the kernel version from the "with-linux" option given to configure then?
>>> I have configured with --with-linux=/lib/modules/`uname -r`/build so that happened to work for me.
>>
>> Would you mind taking a look at the makefile in the directory that you
>> passed to "with-linux" to see how it chooses where to install and run
>> depmod?
>>
>> On mine it does:
>> KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
>> DEPMOD  $(KERNELRELEASE)
>
> I'm not sure how to look at this. The Makefile in my /lib/modules/3.2.0-4-amd64/build is:

I installed a copy of this version of Debian and I have a new method
that I think will be more robust. I'll send out another patch soon.
X-CudaMail-Whitelist-To: dev at openvswitch.org



More information about the dev mailing list