[ovs-dev] [arp-rw 03/13] coverage: Rename coverage_clear() to coverage_run().

Alex Wang alexw at nicira.com
Tue Oct 8 14:29:39 UTC 2013


Since the "reimplement coverage/show" has in, could we make the
coverage_clear() a static function and call it inside the current
coverage_run()?


On Mon, Sep 23, 2013 at 10:49 AM, Ben Pfaff <blp at nicira.com> wrote:

> The new name better reflects what this function does.
>
> Signed-off-by: Ben Pfaff <blp at nicira.com>
> ---
>  lib/coverage.c                |    2 +-
>  lib/coverage.h                |    2 +-
>  lib/timeval.c                 |    2 +-
>  ofproto/ofproto-dpif-upcall.c |    2 +-
>  4 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/lib/coverage.c b/lib/coverage.c
> index 23e2997..30aac71 100644
> --- a/lib/coverage.c
> +++ b/lib/coverage.c
> @@ -238,7 +238,7 @@ coverage_read(struct svec *lines)
>  }
>
>  void
> -coverage_clear(void)
> +coverage_run(void)
>  {
>      size_t i;
>
> diff --git a/lib/coverage.h b/lib/coverage.h
> index 3d1a115..06d2ede 100644
> --- a/lib/coverage.h
> +++ b/lib/coverage.h
> @@ -79,7 +79,7 @@ struct coverage_counter {
>
>  void coverage_init(void);
>  void coverage_log(void);
> -void coverage_clear(void);
> +void coverage_run(void);
>
>  /* Implementation detail. */
>  #define COVERAGE_DEFINE__(COUNTER)                              \
> diff --git a/lib/timeval.c b/lib/timeval.c
> index bd73f35..0798cb0 100644
> --- a/lib/timeval.c
> +++ b/lib/timeval.c
> @@ -230,7 +230,7 @@ time_poll(struct pollfd *pollfds, int n_pollfds, long
> long int timeout_when,
>      int retval;
>
>      time_init();
> -    coverage_clear();
> +    coverage_run();
>      if (*last_wakeup) {
>          log_poll_interval(*last_wakeup);
>      }
> diff --git a/ofproto/ofproto-dpif-upcall.c b/ofproto/ofproto-dpif-upcall.c
> index b210dec..69ce5af 100644
> --- a/ofproto/ofproto-dpif-upcall.c
> +++ b/ofproto/ofproto-dpif-upcall.c
> @@ -411,7 +411,7 @@ udpif_miss_handler(void *arg)
>
>          handle_miss_upcalls(handler->udpif, &misses);
>
> -        coverage_clear();
> +        coverage_run();
>      }
>  }
>
> --
> 1.7.10.4
>
> _______________________________________________
> dev mailing list
> dev at openvswitch.org
> http://openvswitch.org/mailman/listinfo/dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-dev/attachments/20131008/5c498659/attachment-0003.html>


More information about the dev mailing list