[ovs-dev] [PATCH 4/4] odp-util: Parse the in_port as a name correctly.

Gurucharan Shetty shettyg at nicira.com
Mon Sep 23 21:19:50 UTC 2013


Signed-off-by: Gurucharan Shetty <gshetty at nicira.com>
---
 lib/odp-util.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/odp-util.c b/lib/odp-util.c
index 5ca8baf..aec4196 100644
--- a/lib/odp-util.c
+++ b/lib/odp-util.c
@@ -1665,7 +1665,7 @@ parse_odp_key_mask_attr(const char *s, const struct simap *port_names,
         int name_len;
 
         name = s + 8;
-        name_len = strcspn(s, ")");
+        name_len = strcspn(name, ")");
         node = simap_find_len(port_names, name, name_len);
         if (node) {
             nl_msg_put_u32(key, OVS_KEY_ATTR_IN_PORT, node->data);
-- 
1.7.9.5




More information about the dev mailing list