[ovs-dev] [PATCH 1/4] ofproto/xlate: Add xlate_lookup_ofproto().

Ben Pfaff blp at nicira.com
Fri Aug 22 18:15:00 UTC 2014

On Fri, Aug 15, 2014 at 04:38:46PM -0700, Jarno Rajahalme wrote:
> "xlate_receive" did not tell much about what it is used for.  We have
> two users of it that only want the ofproto and the OF port number, use the
> new xlate_lookup_ofproto() for those.
> Fix the comments of xlate_receive() as we no longer change the flow.
> Also, the helper ofproto_dpif_contains_flow() seemed ill-named, so this
> path removes it and uses xlate_lookup_ofproto() directly.
> Signed-off-by: Jarno Rajahalme <jrajahalme at nicira.com>

I think that with some small adjustments, xlate_receive() could call
xlate_lookup_ofproto() and avoid a small amount of duplicated code.

Acked-by: Ben Pfaff <blp at nicira.com>

More information about the dev mailing list