[ovs-dev] [PATCH] ofp-util: Avoid gcc warning on NetBSD

Ben Pfaff blp at nicira.com
Thu Feb 20 16:51:02 UTC 2014


On Thu, Feb 20, 2014 at 11:11:00AM +0900, YAMAMOTO Takashi wrote:
> Avoid the following warning caused by the combination
> of NetBSD's htons implementation and gcc bug.
> Now --enable-Werror build succeeds on NetBSD-6.
> 
>     lib/ofp-util.c: In function 'ofputil_match_from_ofp10_match':
>     lib/ofp-util.c:174:15: error: integer overflow in expression
> 
> Signed-off-by: YAMAMOTO Takashi <yamamoto at valinux.co.jp>

Applied, thanks!



More information about the dev mailing list