[ovs-dev] [PATCH] rhel: Add libcap-ng dependency.

Russell Bryant rbryant at redhat.com
Thu Oct 1 19:50:35 UTC 2015


Commit e91b927d8966bfcb9768225392324dde4fd7d7f6 added optional usage of
the libcap-ng library.  It's packaged in Fedora, so go ahead and added
it to the Fedora spec file.

Our default systemd unit files don't make use of the --user option that
requires this library, but conceivably someone may want to customize
them and use this option.

Signed-off-by: Russell Bryant <rbryant at redhat.com>
---
 rhel/openvswitch-fedora.spec.in | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/rhel/openvswitch-fedora.spec.in b/rhel/openvswitch-fedora.spec.in
index 695f1d7..4e46909 100644
--- a/rhel/openvswitch-fedora.spec.in
+++ b/rhel/openvswitch-fedora.spec.in
@@ -37,13 +37,14 @@ Source: http://openvswitch.org/releases/%{name}-%{version}.tar.gz
 
 BuildRequires: autoconf automake libtool
 BuildRequires: systemd-units openssl openssl-devel
+BuildRequires: libcap-ng libcap-ng-devel
 BuildRequires: python python-twisted-core python-zope-interface PyQt4
 BuildRequires: desktop-file-utils
 BuildRequires: groff graphviz
 # make check dependencies
 BuildRequires: procps-ng
 
-Requires: openssl iproute module-init-tools
+Requires: openssl iproute module-init-tools libcap-ng
 #Upstream kernel commit 4f647e0a3c37b8d5086214128614a136064110c3
 #Requires: kernel >= 3.15.0-0
 
-- 
2.4.3




More information about the dev mailing list