[ovs-dev] [PATCH 1/2] netdev-vport: remove unused function

Binbin Xu xu.binbin1 at zte.com.cn
Wed Aug 10 19:32:19 UTC 2016


The function netdev_vport_get_dpif_port_strdup is not
used anymore. So we can remove it now.

Signed-off-by: Binbin Xu <xu.binbin1 at zte.com.cn>
---
 lib/netdev-vport.c | 9 ---------
 lib/netdev-vport.h | 1 -
 2 files changed, 10 deletions(-)
 mode change 100644 => 100755 lib/netdev-vport.c
 mode change 100644 => 100755 lib/netdev-vport.h

diff --git a/lib/netdev-vport.c b/lib/netdev-vport.c
old mode 100644
new mode 100755
index 87a30f8..f5eb76f
--- a/lib/netdev-vport.c
+++ b/lib/netdev-vport.c
@@ -147,15 +147,6 @@ netdev_vport_get_dpif_port(const struct netdev *netdev,
     }
 }
 
-char *
-netdev_vport_get_dpif_port_strdup(const struct netdev *netdev)
-{
-    char namebuf[NETDEV_VPORT_NAME_BUFSIZE];
-
-    return xstrdup(netdev_vport_get_dpif_port(netdev, namebuf,
-                                              sizeof namebuf));
-}
-
 /* Whenever the route-table change number is incremented,
  * netdev_vport_route_changed() should be called to update
  * the corresponding tunnel interface status. */
diff --git a/lib/netdev-vport.h b/lib/netdev-vport.h
old mode 100644
new mode 100755
index be02cb5..048aa6e
--- a/lib/netdev-vport.h
+++ b/lib/netdev-vport.h
@@ -51,6 +51,5 @@ enum { NETDEV_VPORT_NAME_BUFSIZE = 256 };
 const char *netdev_vport_get_dpif_port(const struct netdev *,
                                        char namebuf[], size_t bufsize)
     OVS_WARN_UNUSED_RESULT;
-char *netdev_vport_get_dpif_port_strdup(const struct netdev *);
 
 #endif /* netdev-vport.h */
-- 
1.8.3.1




More information about the dev mailing list