[ovs-dev] [PATCH v2 1/5] ofproto-dpif: rename wait() to avoid collision with system wait(2)

Lance Richardson lrichard at redhat.com
Tue Mar 15 15:52:55 UTC 2016


Rename ofproto-dpif wait() to avoid collision with wait(2) under OS X.

Signed-off-by: Lance Richardson <lrichard at redhat.com>
---
Changes from v1: None

 ofproto/ofproto-dpif.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/ofproto/ofproto-dpif.c b/ofproto/ofproto-dpif.c
index b963ff2..2402a58 100644
--- a/ofproto/ofproto-dpif.c
+++ b/ofproto/ofproto-dpif.c
@@ -1610,7 +1610,7 @@ run(struct ofproto *ofproto_)
 }
 
 static void
-wait(struct ofproto *ofproto_)
+ofproto_dpif_wait(struct ofproto *ofproto_)
 {
     struct ofproto_dpif *ofproto = ofproto_dpif_cast(ofproto_);
 
@@ -5771,7 +5771,7 @@ const struct ofproto_class ofproto_dpif_class = {
     destruct,
     dealloc,
     run,
-    wait,
+    ofproto_dpif_wait,
     NULL,                       /* get_memory_usage. */
     type_get_memory_usage,
     flush,
-- 
2.5.0




More information about the dev mailing list