[ovs-dev] [PATCH v3 11/13] coverage: Rename init functions to avoid symbol collisions.

Jarno Rajahalme jarno at ovn.org
Mon Sep 12 20:52:41 UTC 2016


ofproto now uses various *_init() functions, so use something else for
coverage constructors.

Signed-off-by: Jarno Rajahalme <jarno at ovn.org>
---
v3: Use '_init_coverage' suffix instead of '_init__'.

 lib/coverage.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/coverage.h b/lib/coverage.h
index 34a04aa..dea990e 100644
--- a/lib/coverage.h
+++ b/lib/coverage.h
@@ -75,7 +75,7 @@ void coverage_counter_register(struct coverage_counter*);
         extern struct coverage_counter counter_##COUNTER;               \
         struct coverage_counter counter_##COUNTER                       \
             = { #COUNTER, COUNTER##_count, 0, 0, {0}, {0} };            \
-        OVS_CONSTRUCTOR(COUNTER##_init) {                               \
+        OVS_CONSTRUCTOR(COUNTER##_init_coverage) {                      \
             coverage_counter_register(&counter_##COUNTER);              \
         }
 
-- 
2.1.4




More information about the dev mailing list