[ovs-dev] [PATCH v8 0/6] netdev-dpdk: Fix mempool management and other cleanup.

Stokes, Ian ian.stokes at intel.com
Fri Oct 27 07:53:51 UTC 2017


> Patch #1, #2 and #4 contain the fixes.
> All other patches in this series are a clean up for code readability or
> small improvements.
> 

Thanks for working on this Antonio and for all the reviews, all comments seem to be resolved and I've validated the patch series.

I pushed this to the dpdk_merge branch

https://github.com/istokes/ovs/tree/dpdk_merge

It will be part of the pull request this week for master.

Thanks
Ian

> List of versions:
>  - v8:
>    - Debug message rephrased in patch #2.
>    - Reworked patch #4 for snprintf error code.
>    - Comments in patch #6 moved into patch #1.
> 
>  - v7:
>    - Restored 2 separate patches for the 2 fixes.
>        - patch #1: detect when previous mempools must be released.
>        - patch #2: mempool name generation for NUMA-awareness test case.
>    - patch "netdev-dpdk: manage empty mempool names." renamed as
>      "netdev-dpdk: manage failure in mempool name creation."
>    - Various rework based on comments.
> 
>  - v6:
>    - patches #1 and #2 squashed into one.
>    - Reworked to consider the latest comments.
>    - tested the release of pre-existing mempools (reported by Ciara L.)
>    - tested the change of MTU when an existing mempool is returned
>      (reported by Robert M.)
>    - tested the NUMA-Awareness usecase (reported by Ciara L.)
>  - v5: manage new MTU value when a pre-existing mempool is returned.
>  - v4: fix NUMA awareness usecase
>  - v3: avoid deletion of pre-existing mempools
>  - v2: rework to accomodate code changes for dpdk ports too
>  - v1: 1st implementation.
> 
> Fischetti, Antonio (6):
>   netdev-dpdk: fix management of pre-existing mempools.
>   Fix mempool names to reflect socket id.
>   netdev-dpdk: skip init for existing mempools.
>   netdev-dpdk: manage failure in mempool name creation.
>   netdev-dpdk: Reword mp_size as n_mbufs.
>   netdev-dpdk: Rename dpdk_mp_put as dpdk_mp_free.
> 
>  lib/netdev-dpdk.c | 96 ++++++++++++++++++++++++++++++++++----------------
> -----
>  1 file changed, 59 insertions(+), 37 deletions(-)
> 
> --
> 2.4.11
> 
> _______________________________________________
> dev mailing list
> dev at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-dev


More information about the dev mailing list