[ovs-dev] [PATCH] poc: Automate building of Fedora rpm packages

Ansis Atteka ansisatteka at gmail.com
Tue Apr 24 20:59:38 UTC 2018

On 24 April 2018 at 13:10, Aaron Conole <aconole at redhat.com> wrote:
> Ansis Atteka <aatteka at ovn.org> writes:
>> This patch automates building of Fedora rpm packages (Just
>> like we are already doing this for for CentOS and Ubuntu).
>> Signed-off-by: Ansis Atteka <aatteka at ovn.org>
>> ---
> Maybe it's something wrong with my setup - but for the fedorabuilder
> image I get a stall "Waiting for domain to get an IP address..." and it
> doesn't proceed.  On the other hand, the centos and ubuntu still proceed
> as normal.

Thanks for trying this out!

> Are you also able to observe this?  I probably did something wrong, but
> all I did was:
>   $ git am ~/News/poc.patch
>   $ vagrant up fedorabuilder

That is exactly the same command I ran. Though, I believe your default
provider is libvirt and not virtualbox?

>   ...
>   ==> fedorabuilder: Starting domain.
>   ==> fedorabuilder: Waiting for domain to get an IP address...

I reproduced the exact same error with --provider=libvirt argument.
Thanks for catching this. I suspect that generic/fedora27 works on
virtualbox, but does not work on libvirt. Will try to find fedora27
box that works with both providers.

>   ==> fedorabuilder: Removing domain...
>   ==> fedorabuilder: An error occurred. The error will be shown after all tasks complete.
>   An error occurred while executing multiple actions in parallel.
>   Any errors that occurred are shown below.
>   An unexpected error occurred when executing the action on the
>   'fedorabuilder' machine. Please report this as a bug:
>   The specified wait_for timeout (2 seconds) was exceeded
>   /usr/share/gems/gems/fog-core-1.43.0/lib/fog/core/wait_for.rb:9:in `block in wait_for'
>   /usr/share/gems/gems/fog-core-1.43.0/lib/fog/core/wait_for.rb:6:in `loop'
>   /usr/share/gems/gems/fog-core-1.43.0/lib/fog/core/wait_for.rb:6:in `wait_for'
>   /usr/share/gems/gems/fog-core-1.43.0/lib/fog/core/model.rb:69:in `wait_for'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/wait_till_up.rb:42:in `block (2 levels) in call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/util/retryable.rb:17:in `retryable'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/wait_till_up.rb:37:in `block in call'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/util/timer.rb:9:in `time'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/wait_till_up.rb:34:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/action/warden.rb:34:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/start_domain.rb:298:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/action/warden.rb:34:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/set_boot_order.rb:78:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/action/warden.rb:34:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/create_network_interfaces.rb:176:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/action/warden.rb:34:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/create_networks.rb:83:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/action/warden.rb:34:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/share_folders.rb:20:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/action/warden.rb:34:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-libvirt-0.0.40/lib/vagrant-libvirt/action/prepare_nfs_settings.rb:18:in `call'
>   /usr/share/vagrant/gems/gems/vagrant-2.0.2/lib/vagrant/action/warden.rb:34:in `call'
>   ...
> -Aaron

More information about the dev mailing list