[ovs-dev] [ PATCH v2] dpdk: Use DPDK 17.11.2 release.

Stokes, Ian ian.stokes at intel.com
Wed Apr 25 09:17:45 UTC 2018


> Modify travis linux build script to use the latest DPDK stable release
> 17.11.2. Update docs for latest DPDK stable releases.
> 

Thanks for this Kevin, I'm lining this up for the next pull request.

Minor comments inline.

> Signed-off-by: Kevin Traynor <ktraynor at redhat.com>
> ---
>  .travis/linux-build.sh                   | 2 +-
>  Documentation/faq/releases.rst           | 4 ++--
>  Documentation/intro/install/dpdk.rst     | 8 ++++----
>  Documentation/topics/dpdk/vhost-user.rst | 8 ++++----
>  4 files changed, 11 insertions(+), 11 deletions(-)
> 
> diff --git a/.travis/linux-build.sh b/.travis/linux-build.sh index
> 19b2ccf..2e611f8 100755
> --- a/.travis/linux-build.sh
> +++ b/.travis/linux-build.sh
> @@ -84,5 +84,5 @@ fi
>  if [ "$DPDK" ]; then
>      if [ -z "$DPDK_VER" ]; then
> -        DPDK_VER="17.11.1"
> +        DPDK_VER="17.11.2"
>      fi
>      install_dpdk $DPDK_VER
> diff --git a/Documentation/faq/releases.rst
> b/Documentation/faq/releases.rst index 7c65503..db912ff 100644
> --- a/Documentation/faq/releases.rst
> +++ b/Documentation/faq/releases.rst
> @@ -164,7 +164,7 @@ Q: What DPDK version does each Open vSwitch release
> work with?
>      2.5.x        2.2
>      2.6.x        16.07.2
> -    2.7.x        16.11.5
> +    2.7.x        16.11.6
>      2.8.x        17.05.2

I'm not sure from the DPDK side are there plans to backport the fix for CVE-2018-1059 that are addressed in this release.

If not then I'd assume we should flag that that issue is present for OVS where it uses an affected DPDK. (OVS 2.8, OVS 2.6?).


> -    2.9.x        17.11.1
> +    2.9.x        17.11.2
>      ============ =======
> 
> diff --git a/Documentation/intro/install/dpdk.rst
> b/Documentation/intro/install/dpdk.rst
> index fea4890..34cd0ea 100644
> --- a/Documentation/intro/install/dpdk.rst
> +++ b/Documentation/intro/install/dpdk.rst
> @@ -41,5 +41,5 @@ In addition to the requirements described in
> :doc:`general`, building Open  vSwitch with DPDK will require the
> following:
> 
> -- DPDK 17.11.1
> +- DPDK 17.11.2
> 
>  - A `DPDK supported NIC`_
> @@ -70,7 +70,7 @@ Install DPDK
> 
>         $ cd /usr/src/
> -       $ wget http://fast.dpdk.org/rel/dpdk-17.11.1.tar.xz
> -       $ tar xf dpdk-17.11.1.tar.xz
> -       $ export DPDK_DIR=/usr/src/dpdk-stable-17.11.1
> +       $ wget http://fast.dpdk.org/rel/dpdk-17.11.2.tar.xz
> +       $ tar xf dpdk-17.11.2.tar.xz
> +       $ export DPDK_DIR=/usr/src/dpdk-stable-17.11.2
>         $ cd $DPDK_DIR
> 
> diff --git a/Documentation/topics/dpdk/vhost-user.rst
> b/Documentation/topics/dpdk/vhost-user.rst
> index ca8a328..755a70d 100644
> --- a/Documentation/topics/dpdk/vhost-user.rst
> +++ b/Documentation/topics/dpdk/vhost-user.rst
> @@ -324,7 +324,7 @@ DPDK sources to VM and build DPDK::
> 
>      $ cd /root/dpdk/
> -    $ wget http://fast.dpdk.org/rel/dpdk-17.11.1.tar.xz
> -    $ tar xf dpdk-17.11.1.tar.xz
> -    $ export DPDK_DIR=/root/dpdk/dpdk-stable-17.11.1
> +    $ wget http://fast.dpdk.org/rel/dpdk-17.11.2.tar.xz
> +    $ tar xf dpdk-17.11.2.tar.xz
> +    $ export DPDK_DIR=/root/dpdk/dpdk-stable-17.11.2
>      $ export DPDK_TARGET=x86_64-native-linuxapp-gcc
>      $ export DPDK_BUILD=$DPDK_DIR/$DPDK_TARGET @@ -410,5 +410,5 @@ Sample
> XML
>          <disk type='dir' device='disk'>
>            <driver name='qemu' type='fat'/>
> -          <source dir='/usr/src/dpdk-stable-17.11.1'/>
> +          <source dir='/usr/src/dpdk-stable-17.11.2'/>
>            <target dev='vdb' bus='virtio'/>
>            <readonly/>

Just FYI, I've removed the xml change above when applying this patch as mounting the QEMU drive is removed altogether in the current pending pull request.

Ian

> --
> 1.8.3.1
> 
> _______________________________________________
> dev mailing list
> dev at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-dev


More information about the dev mailing list