[ovs-dev] [PATCH] Docs: Improve OVS DPDK version mapping notice.

Ian Stokes ian.stokes at intel.com
Thu Jul 12 18:48:42 UTC 2018


A common issue is users pairing the incorrect version of OVS to DPDK
when working outside of the build tree.

To avoid this this commit updates the OVS DPDK documentation to explicitly
flag that users should consult the OVS to DPDK release mapping in FAQ if
working outside of the OVS build tree.

Suggested-by: Ben Pfaff <blp at ovn.org>
Signed-off-by: Ian Stokes <ian.stokes at intel.com>
---
 Documentation/howto/dpdk.rst         | 6 ++++--
 Documentation/intro/install/dpdk.rst | 6 ++++--
 2 files changed, 8 insertions(+), 4 deletions(-)

diff --git a/Documentation/howto/dpdk.rst b/Documentation/howto/dpdk.rst
index 82596f5..ab3d576 100644
--- a/Documentation/howto/dpdk.rst
+++ b/Documentation/howto/dpdk.rst
@@ -29,8 +29,10 @@ This document describes how to use Open vSwitch with DPDK datapath.
 
 .. important::
 
-   Using the DPDK datapath requires building OVS with DPDK support. Refer to
-   :doc:`/intro/install/dpdk` for more information.
+   Using the DPDK datapath requires building OVS with DPDK support. The
+   mapping of OVS version to DPDK can vary between releases. For version
+   mapping information refer to :doc:`releases FAQ </faq/releases>`. For
+   build instructions refer to :doc:`/intro/install/dpdk`.
 
 Ports and Bridges
 -----------------
diff --git a/Documentation/intro/install/dpdk.rst b/Documentation/intro/install/dpdk.rst
index 2468c64..407435a 100644
--- a/Documentation/intro/install/dpdk.rst
+++ b/Documentation/intro/install/dpdk.rst
@@ -29,10 +29,12 @@ This document describes how to build and install Open vSwitch using a DPDK
 datapath. Open vSwitch can use the DPDK library to operate entirely in
 userspace.
 
-.. seealso::
+.. Important::
 
     The :doc:`releases FAQ </faq/releases>` lists support for the required
-    versions of DPDK for each version of Open vSwitch.
+    versions of DPDK for each version of Open vSwitch. If building OVS and
+    DPDK outside of the master build tree users should consult this list
+    first.
 
 Build requirements
 ------------------
-- 
2.7.5



More information about the dev mailing list