[ovs-dev] Fwd: [PATCH 1/1] ovsdb-idl: memory leak while destroying database

Aaron Conole aconole at redhat.com
Mon Jul 1 14:16:32 UTC 2019


Damjan Skvarc <damjan.skvarc at gmail.com> writes:

> Hm, telling the true, I don't know how to react on this report. 
> - I have made a slight change on MY LOCAL OVS FORK 
> - created a patch file (git format-patch -1 -s -n)
> - prepare a mail (according to documentation)
> - and sent it to dev list.
> probably a problem occurred, because on my local ovs fork I have some other commits?

Not sure.  I'll say this, there's something wrong in the following hunk.

index 7545e43..d64d8c0 100644
--- a/lib/ovsdb-idl.c
+++ b/lib/ovsdb-idl.c
@@ -239,6 +239,7 @@ static bool ovsdb_idl_check_server_db(struct ovsdb_idl
*);
 static void ovsdb_idl_send_monitor_request(struct ovsdb_idl *,
                                            struct ovsdb_idl_db *,
                                            enum ovsdb_idl_monitor_method);
+static void ovsdb_idl_db_clear(struct ovsdb_idl_db *db);


Note that it looks like it was line-wrapped, possibly by your email
client.  Can you double check your mail client settings?  If you look in
Patchwork at your patch: https://patchwork.ozlabs.org/patch/1125186/
you'll see that even patchwork didn't detect it correctly.  And if I
manually take your email from the mailing list, I see the same error.

I would suggest trying to send again, and see if you can clear any
formatting options.

> Now I have applied the same changes on CLONED OVS repository and I am attaching unmodified file (git
> format-patch -1 -s -n) if you
> are willing to help me. Or should I do something other?
> thanks, damijan
>
> ---------- Forwarded message ---------
> Od: 0-day Robot <robot at bytheb.org>
> Date: V pon., 1. jul. 2019 ob 12:58
> Subject: Re: [ovs-dev] [PATCH 1/1] ovsdb-idl: memory leak while destroying database
> To: Damjan Skvarc <damjan.skvarc at gmail.com>
> Cc: <dev at openvswitch.org>
>
> Bleep bloop.  Greetings Damjan Skvarc, I am a robot and I have tried out your patch.
> Thanks for your contribution.
>
> I encountered some error that I wasn't expecting.  See the details below.
>
> git-am:
> fatal: patch fragment without header at line 6: @@ -581,8 +582,9 @@ ovsdb_idl_destroy(struct ovsdb_idl *idl)
> Repository lacks necessary blobs to fall back on 3-way merge.
> Cannot fall back to three-way merge.
> Patch failed at 0001 ovsdb-idl: memory leak while destroying database
> The copy of the patch that failed is found in:
>    /var/lib/jenkins/jobs/upstream_build_from_pw/workspace/.git/rebase-apply/patch
> When you have resolved this problem, run "git am --resolved".
> If you prefer to skip this patch, run "git am --skip" instead.
> To restore the original branch and stop patching, run "git am --abort".
>
> Please check this out.  If you feel there has been an error, please email aconole at bytheb.org
>
> Thanks,
> 0-day Robot


More information about the dev mailing list