[ovs-dev] [PATCH v1] ovs container build.sh requires python3

amginwal at gmail.com amginwal at gmail.com
Fri Oct 11 20:58:25 UTC 2019


From: Aliasgar Ginwala <aginwala at ebay.com>

building ovn/ovs container breaks while configure:
checking for Python 3 (version 3.4 or later)... no
configure: error: Python 3.4 or later is required but not found in
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin,
please install it or set  to point to it

As per commit 1ca0323e7c29dc7ef5a615c265df0460208f92de
Require Python 3 and remove support for Python 2.

Signed-off-by: Aliasgar Ginwala <aginwala at ebay.com>
---
 utilities/docker/debian/build-kernel-modules.sh | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/utilities/docker/debian/build-kernel-modules.sh b/utilities/docker/debian/build-kernel-modules.sh
index 1b12720b9..18ac35764 100755
--- a/utilities/docker/debian/build-kernel-modules.sh
+++ b/utilities/docker/debian/build-kernel-modules.sh
@@ -18,8 +18,8 @@ GITHUB_SRC=$3
 
 # Install deps
 linux="linux-image-$KERNEL_VERSION linux-headers-$KERNEL_VERSION"
-build_deps="apt-utils libelf-dev build-essential libssl-dev python \
-python-six wget gdb autoconf libtool git automake bzip2 debhelper \
+build_deps="apt-utils libelf-dev build-essential libssl-dev python3 \
+python3-six wget gdb autoconf libtool git automake bzip2 debhelper \
 dh-autoreconf openssl"
 
 apt-get update
-- 
2.20.1 (Apple Git-117)



More information about the dev mailing list