[ovs-dev] [PATCH] compat: Include confirm_neigh parameter if needed

Ilya Maximets i.maximets at ovn.org
Tue Jan 7 17:13:32 UTC 2020


On 07.01.2020 18:08, Simon Horman wrote:
> On Tue, Jan 07, 2020 at 10:34:37AM +0100, Simon Horman wrote:
>> On Mon, Jan 06, 2020 at 01:36:34PM -0800, Greg Rose wrote:
>>> A change backported to the Linux 4.14.162 LTS kernel requires
>>> a boolean parameter.  Check for the presence of the parameter
>>> and adjust the caller in that case.
>>>
>>> Passes check-kmod test with no regressions.
>>>
>>> Passes Travis build here:
>>> https://travis-ci.org/gvrose8192/ovs-experimental/builds/633461320
>>>
>>> Signed-off-by: Greg Rose <gvrose8192 at gmail.com>
>>
>> Thanks Greg,
>>
>> I have pushed this to master with a view to quickly resolving
>> the build problem there.
>>
>> I also plan to push the change to to branch-2.10 ... 2.12
>> once I've confirmed the problem exists there and testing of those backports
>> is complete:
>>
>>   branch-2.12: https://travis-ci.org/horms2/ovs/builds/633651396
>>   branch-2.12 + backport: https://travis-ci.org/horms2/ovs/builds/633674666
>>   branch-2.11: https://travis-ci.org/horms2/ovs/builds/633651456
>>   branch-2.11 + backport: https://travis-ci.org/horms2/ovs/builds/633676376
>>   branch-2.10: https://travis-ci.org/horms2/ovs/builds/633676916
>>   branch-2.10 + backport: https://travis-ci.org/horms2/ovs/builds/633677490
> 
> Empirically it appears the backport is only needed
> for branch-2.12, I have pushed it there.
> 

We might still consider backporting.  Travis doesn't fail on branches before 2.12
only because commit c94e2d64f05e ("travis: Test with latest stable kernel releases.")
was introduced in 2.12. On earlier branches we're using older versions of stable
kernels.  These branches could still fail to build if we'll try to build them with
4.14.162.

Best regards, Ilya Maximets.


More information about the dev mailing list