[ovs-dev] ModuleNotFoundError: No module named 'ovs'

Ravi Kerur rkerur at gmail.com
Wed Jun 24 11:39:10 UTC 2020


Hi,

I am using OVS 2.13.90 and getting errors when I run

ovs-vtep

Traceback (most recent call last):

  File "/usr/local/share/openvswitch/scripts/ovs-vtep", line 26, in <module>

    import ovs.daemon

ModuleNotFoundError: No module named 'ovs'



pip install ovs

Requirement already satisfied: ovs in /usr/local/lib/python2.7/dist-packages

Requirement already satisfied: sortedcontainers in
/usr/local/lib/python2.7/dist-packages (from ovs)

If I run 'import' from python shell it works fine

python

Python 2.7.17 (default, Nov  7 2019, 10:07:09)

[GCC 7.4.0] on linux2

Type "help", "copyright", "credits" or "license" for more information.

>>> import ovs.daemon

>>> import ovs.dirs

>>> import ovs.unixctl.server

>>> import ovs.util

>>> import ovs.vlog

>>>

OVS is installed with '/usr/local' as a prefix. Anything I need to do to
get 'ovs-vtep' working?

Thanks.


More information about the dev mailing list