[ovs-dev] [PATCH V3 1/9] acinclude: Enable Linux kernel 5.5

Yi-Hung Wei yihung.wei at gmail.com
Fri Mar 6 18:26:34 UTC 2020


On Wed, Mar 4, 2020 at 3:04 PM Greg Rose <gvrose8192 at gmail.com> wrote:
>
> Signed-off-by: Greg Rose <gvrose8192 at gmail.com>
> ---
>  acinclude.m4 | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/acinclude.m4 b/acinclude.m4
> index 1212a46..db64267 100644
> --- a/acinclude.m4
> +++ b/acinclude.m4
> @@ -151,7 +151,7 @@ AC_DEFUN([OVS_CHECK_LINUX], [
>      AC_MSG_RESULT([$kversion])
>
>      if test "$version" -ge 5; then
> -       if test "$version" = 5 && test "$patchlevel" -le 0; then
> +       if test "$version" = 5 && test "$patchlevel" -le 5; then
>            : # Linux 5.x
>         else
>            AC_ERROR([Linux kernel in $KBUILD is version $kversion, but version newer than 5.0.x is not supported (please refer to the FAQ for advice)])

Opps, I just found that we should update the version number in the
AC_ERROR message as well. Somehow I did not find it in the previous
review.

With the version number update.

Acked-by: Yi-Hung Wei <yihung.wei at gmail.com>


-Yi-Hung


More information about the dev mailing list