[ovs-dev] [PATCH V3 9/9] datapath: Update kernel test list

Gregory Rose gvrose8192 at gmail.com
Fri Mar 6 21:07:34 UTC 2020


On 3/6/2020 11:18 AM, Yi-Hung Wei wrote:
> On Wed, Mar 4, 2020 at 3:04 PM Greg Rose <gvrose8192 at gmail.com> wrote:
>> We are adding support for Linux kernels up to 5.5 so update the
>> Travis test list, NEWS and FAQ.
>>
>> Signed-off-by: Greg Rose <gvrose8192 at gmail.com>
>>
>> ---
>> V3 - Squash separate commits for Travis, NEWS and FAQ
>> ---
>>   .travis.yml                    | 2 +-
>>   Documentation/faq/releases.rst | 1 +
>>   NEWS                           | 2 ++
>>   3 files changed, 4 insertions(+), 1 deletion(-)
>>
>> diff --git a/.travis.yml b/.travis.yml
>> index abd2a91..ef9f867 100644
>> --- a/.travis.yml
>> +++ b/.travis.yml
>> @@ -38,7 +38,7 @@ env:
>>     - TESTSUITE=1 OPTS="--enable-shared"
>>     - TESTSUITE=1 DPDK=1
>>     - TESTSUITE=1 LIBS=-ljemalloc
>> -  - KERNEL_LIST="5.0  4.20 4.19 4.18 4.17 4.16"
>> +  - KERNEL_LIST="5.5  4.20 4.19 4.18 4.17 4.16"
> Hi Greg,
>
> Any reason we want to skip build test with 5.0 kernel?

5.0 isn't on the LTS list at kernel.org so I dropped it.  No real reason 
for 4.20
either but I left it there.  Technically 5.5 isn't on the LTS list 
either, but
it is the current stable.

>
>
>>     - KERNEL_LIST="4.15 4.14 4.9  4.4  3.19 3.16"
>>     - AFXDP=1 KERNEL=5.3
>>     - M32=1 OPTS="--disable-ssl"
>> diff --git a/Documentation/faq/releases.rst b/Documentation/faq/releases.rst
>> index 6ff47d7..a073b97 100644
>> --- a/Documentation/faq/releases.rst
>> +++ b/Documentation/faq/releases.rst
>> @@ -70,6 +70,7 @@ Q: What Linux kernel versions does each Open vSwitch release work with?
>>       2.10.x       3.10 to 4.17
>>       2.11.x       3.10 to 4.18
>>       2.12.x       3.10 to 5.0
>> +    2.13.x       3.10 to 5.5
> Since this patch series is for the master branch, and we general do
> not backport new features back to older branch.
>
> Maybe we should update as the following?
>
> +    2.13.x       3.10 to 5.0
> +    2.14.x       3.10 to 5.5

You are correct.

Maintainers, if you could fix that up on commit please let me know,
otherwise I'm fine with sending an updated patch series.

Thanks,

- Greg



More information about the dev mailing list