[ovs-dev] [PATCH RFC ovn] Add VXLAN support for non-VTEP datapath bindings

Ihar Hrachyshka ihrachys at redhat.com
Thu Mar 26 00:58:43 UTC 2020

On Tue, Mar 24, 2020 at 9:18 AM Numan Siddique <numans at ovn.org> wrote:
> (Sorry, top posting it)
> Hi Ihar,
> I tested out your patch. All the tests pass.
> I then tested out using the ovn-fake-multinode [1].
> After the deployment, I changed the encap to vxlan. East/West traffic
> worked fine
> without any issues.. But I was not able to ping to the gateway router port IP
> from outside ( The moment I changed the encap back to
> geneve, the ping
> works. I didn't look into the issue. So not sure what's the reason.
> You may want to try out
> once with ovn-fake-multinode
> Thanks
> Numan
> [1] - https://github.com/ovn-org/ovn-fake-multinode/

Hi Numan,

I've tried to find which issue you experience with N-S and I failed to
reproduce it with ovn-fake-multinode or with a test case as part of
the suite (I retrofitted a N-S test case that uses geneve for this
matter, leaving everything as is but changing the encap type to vxlan
- it passes as expected). For fake-multinode, here is what I do:

[vagrant at ovnhostvm ~]$ sudo ip netns exec ovnfake-ext ping -c 1
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.070 ms

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.070/0.070/0.070/0.000 ms

Is there something I am missing? (May very well be the case, perhaps I
validate outside connectivity to the router incorrectly.)

Let me know.

More information about the dev mailing list