[ovs-dev] [PATCH] flex-array: allow arrays of unions with flexible members.

Luc Van Oostenryck luc.vanoostenryck at gmail.com
Wed Oct 7 23:15:54 UTC 2020


On Wed, Oct 07, 2020 at 01:52:34PM +0200, Ilya Maximets wrote:
> The actual code in question that makes sparse fail
> OVS build could be found here:
>   https://github.com/openvswitch/ovs/blob/39fbd2c3f0392811689ec780f09baf90faceb877/lib/netdev-linux.c#L1238

I'm impressed and surprised you're using of includes just for Sparse.
I also see that this is since 2011. Just for my curiosity, have
you an idea for why exactly this was needed and if it is still
really needed?

-- Luc


More information about the dev mailing list