[ovs-dev] [PATCH ovn v2 2/2] lflow.c: Release ref_lflow_node as soon as it is not needed.
dceara at redhat.com
Wed Sep 16 17:51:32 UTC 2020
On 9/16/20 2:18 PM, Dumitru Ceara wrote:
>> + hmap_remove(&lfrr->ref_lflow_table, &lrln->rlfn->node);
>> + ref_lflow_node_destroy(lrln->rlfn);
> As mentioned on v1 (at least for me) it's really hard to keep track of
> what's going on due to the variable/field names, e.g., "lrln->rlfn". I'd
> really like it if we had somewhat more explicit names.
This can be done as a follow up patch. I guess the goal is to fix the
crash as soon as possible. Refactoring should come afterwards.
More information about the dev