[ovs-dev] [PATCH ovn v2 3/5] github: Use nmap-ncat instead of netcat-openbsd.

Mark Gray mark.d.gray at redhat.com
Thu Jun 10 16:28:46 UTC 2021


On 09/06/2021 13:12, Dumitru Ceara wrote:
> There are some bugs in the netcat-openbsd version shipped with Ubuntu
> 20.04.  Switch to nmap-ncat to avoid system tests that will be added
> by upcoming commits fail in CI.
> 
> One example:
> 
> 1. Start a TCP connection from IP1:port-x to IP2:port-y.
> 2. Start a TCP connection from IP1:port-x to IP3:port-z.
> 
> netcat-openbsd fails with:
>   nc: bind failed: Address already in use
> 
> Signed-off-by: Dumitru Ceara <dceara at redhat.com>
> ---
>  .github/workflows/test.yml |    5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
> index d7bb7eecf..071e54fa0 100644
> --- a/.github/workflows/test.yml
> +++ b/.github/workflows/test.yml
> @@ -13,7 +13,7 @@ jobs:
>        dependencies: |
>          automake libtool gcc bc libjemalloc2 libjemalloc-dev    \
>          libssl-dev llvm-dev libelf-dev libnuma-dev libpcap-dev  \
> -        selinux-policy-dev
> +        selinux-policy-dev ncat
>        m32_dependecies: gcc-multilib
>        CC:          ${{ matrix.compiler }}
>        LIBS:        ${{ matrix.libs }}
> @@ -76,6 +76,9 @@ jobs:
>      - name: update APT cache
>        run:  sudo apt update
>  
> +    - name: remove netcat-openbsd
> +      run:  sudo apt remove -y netcat-openbsd
> +
>      - name: install required dependencies
>        run:  sudo apt install -y ${{ env.dependencies }}
>  
> 

Acked-by: Mark D. Gray <mark.d.gray at redhat.com>



More information about the dev mailing list