[ovs-dev] [PATCH] build: check libibverbs deps before linking with dpdk

David Marchand david.marchand at redhat.com
Wed Nov 10 12:36:12 UTC 2021


On Wed, Nov 10, 2021 at 1:16 PM Harold Huang <baymaxhuang at gmail.com> wrote:
>
> Hi, Maximets,
>
> I have found this build error message in both dpdk 20.11.3 and
> 20.11.1.  I did not make any change to dpdk. I use the following
> command to build dpdk:
>
>  meson builddir && cd builddir &&   meson configure
> --prefix=/usr/local -Dexamples='' -Dtests=false -Denable_kmods=false
> -Denable_docs=false
> -Ddisable_drivers=event/*,crypto/*,net/mlx4,net/mlx5 &&   ninja &&
> ninja install
>
> I am also puzzled because DPDK is built successfully and it does not
> need libibverbs.

The common/mlx5 driver is still enabled with this configuration.
Try: -Ddisable_drivers=event/*,crypto/*,net/mlx4,*/mlx5

-- 
David Marchand



More information about the dev mailing list