[ovs-dev] [PATCH ovn branch-21.09] ovs: Update submodule to include removal of pyopenssl.

Mark Michelson mmichels at redhat.com
Thu Nov 11 20:20:23 UTC 2021


On 11/11/21 14:04, Ilya Maximets wrote:
> On 11/11/21 19:02, Mark Michelson wrote:
>> RHEL 9 and CentOS 9 no longer contain a pyopenssl package. Therefore,
>> for RHEL 9 and CentOS 9 builds of OVN, we need to no longer rely on the
>> pyopenssl package. OVS's python IDL was recently updated to no longer
>> depend on pyopenssl, favoring instead to use the built-in SSL module.
>>
>> This commit pulls in that change so that packages of OVN 21.09 can be
>> made without the dependency of pyopenssl.
>>
>> Signed-off-by: Mark Michelson <mmichels at redhat.com>
>> ---
>>   ovs | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/ovs b/ovs
>> index 429b114c5..68543dd52 160000
>> --- a/ovs
>> +++ b/ovs
>> @@ -1 +1 @@
>> -Subproject commit 429b114c5aadee24ccfb16ad7d824f45cdcea75a
>> +Subproject commit 68543dd523bd00f53fa7b91777b962ccb22ce679
>>
> 
> Hey, Mark.
> 
> Current version of a submodule is already
> 1bdda7b6d53c92e877b457157676aff326414c53, which is newer than
> the version you're trying to update to with this patch.
> 
> Best regards, Ilya Maximets.
> 

Ah, sorry for the confusion. I failed to note that my patch is for 
branch-21.09, which is on an older commit from OVS. I neglected to 
indicate this in the subject line. I've amended it now.



More information about the dev mailing list