[ovs-discuss] Open vSwitch installation in userspace.

Hardeep Uppal hardeep.uw at gmail.com
Wed Aug 4 22:19:33 UTC 2010


I was running in userspace to quickly get something up and running. Also I
didn't have the dom0 kernel code when I first started with Open vSwitch.
Hence when I ran "./configure
--with-l26=/lib/modules/2.6.26-2-xen-686/build" i got an error saying that
the build directory was missing. I am going to take your suggestion and use
the kernel module. I downloaded the header for  2.6.26-2-xen-686, but I need
to figure out how to link it to the kernel and have a build folder.

Thanks

--Hardeep

On Wed, Aug 4, 2010 at 2:12 PM, Jesse Gross <jesse at nicira.com> wrote:

> On Wed, Aug 4, 2010 at 1:32 PM, Hardeep Uppal <hardeep.uw at gmail.com>wrote:
>
>> Hi Jesse,
>>
>> Thanks for your reply. I can see that OpenvSwicth created the bridge br0.
>> But when I update my domU.cfg file to update the network bridge to br0 from
>> eth0, domU does not boot and I get the following error
>>
>> $ sudo xm create domU.cfg
>>    Using config file "/etc/xen/domU.cfg".
>>    Error: Device 0 (vif) could not be connected. Hotplug scripts not
>> working.
>>
>> The bridge should be visible to Xen right? I can see the bridge when I run
>> ifconfig.
>>
>> ettm at ettm:~$ ifconfig
>> br0       Link encap:Ethernet  HWaddr 00:25:64:49:d7:94
>>           inet addr:128.xxx.x.xx  Bcast:128.208.3.255  Mask:255.255.255.0
>>           inet6 addr: fe80::225:64ff:fe49:d794/64 Scope:Link
>>           UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
>>           RX packets:14330 errors:0 dropped:0 overruns:0 frame:0
>>           TX packets:1313 errors:0 dropped:0 overruns:0 carrier:0
>>           collisions:0 txqueuelen:500
>>           RX bytes:2297956 (2.2 MB)  TX bytes:463836 (463.8 KB)
>>
>>
>> Do I need to do something else to make domU use br0 created by open
>> vswicth?
>>
>
> Xen is expecting to use the bridge tools to connect the virtual interface.
>  Since Open vSwitch is not the bridge, you either need to modify the Xen
> scripts to use the Open vSwitch commands directly or use our bridge
> compatibility layer, which as I mentioned requires kernel support.  Is there
> a reason why you need to run in userspace?
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100804/e8abea4c/attachment-0001.html>


More information about the discuss mailing list