[ovs-discuss] openflow version incompatible with nox?

kk yap yapkke at stanford.edu
Wed Aug 11 03:39:58 UTC 2010


Note the need to checkout the openflow-1.0 branch.  :)

Regards
KK

2010/8/10 陈文龙 <qzchenwl at gmail.com>:
> Compiled source from git://noxrepo.org/nox.
> It occurs the same problem.
>
> OVS 1.0.1
> NOX 0.8.0
>
>> debian1:~/nox/src# ./nox_core -i ptcp:2525 packetdump
>> NOX 0.8.0~full~beta (nox_core), compiled Aug 11 2010 07:24:38
>> Compiled with OpenFlow 0x97 (exp)
>> 00001|openflow|WARN:stream: version negotiation failed: we support
>> versions 0x97 to 0x97 inclusive but peer supports no later than version 0x01
>> 00002|nox|WARN:Error sending features request: Protocol error
>
>
>
>
> 在 2010年8月11日 上午11:12,陈文龙 <qzchenwl at gmail.com>写道:
>>
>> thanks, trying the git version.
>>
>> report latter.
>>
>>
>> 在 2010年8月11日 上午11:06,kk yap <yapkke at stanford.edu>写道:
>>>
>>> Why not try openflow-1.0 branch of NOX0.6 at git://noxrepo.org/nox?
>>>
>>> Regards
>>> KK
>>>
>>> On 10 August 2010 19:55, 陈文龙 <qzchenwl at gmail.com> wrote:
>>> > OVS 1.0.1
>>> > NOX 0.5.0
>>> > Is that ok?
>>> >
>>> > 2010/8/11 Ben Pfaff <blp at nicira.com>
>>> >>
>>> >> On Tue, Aug 10, 2010 at 6:59 PM, 陈文龙 <qzchenwl at gmail.com> wrote:
>>> >> > OVS runs in Dom0. NOX runs in DomU.
>>> >> >
>>> >> >
>>> >> > 00001|openflow|WARN:stream: version negotiation failed: we support
>>> >> > versions
>>> >> > 0x97 to 0x97 inclusive but peer supports no later than version 0x01
>>> >> > 00002|nox|WARN:Error sending features request: Protocol error
>>> >> >
>>> >> > OVS support OF version 0x97 but NOX do not?
>>> >>
>>> >> I think you have it backward.  Any recent OVS supports OpenFlow 1.0
>>> >> (0x01).
>>> >> I think you must be using an old version of NOX that does not.
>>> >
>>> >
>>> > _______________________________________________
>>> > discuss mailing list
>>> > discuss at openvswitch.org
>>> > http://openvswitch.org/mailman/listinfo/discuss_openvswitch.org
>>> >
>>> >
>>
>
>




More information about the discuss mailing list