[ovs-discuss] Problem with Open vSwitch as an OpenFlow Switch

Thomas Hoehn thomas.hoehn at informatik.uni-wuerzburg.de
Thu Aug 19 10:28:20 UTC 2010


Hello,
i have a problem to run the Open vSwitch with OpenFlow. I have 
configured the switch like it is described in the tutorial "How to 
Install Open vSwitch on Linux". Then i started the ovsdb-server with 
the command:

% vsdb-server /usr/local/etc/ovs-vswitchd.conf.db 
--remote=punix:/usr/local/var/run/openvswitch/db.sock

Then i started the main Open vSwitch daemon with the command:

% ovs-vswitchd unix:/usr/local/var/run/openvswitch/db.sock

So far so good.
If i configure a normal bridge the Open vSwitch works, but not with 
OpenFlow.
If i configure the Switch like it is described in the tutorial "Using 
Open vSwitch as an OpenFlow Switch" with an out-of-band control i 
become this error message:

%ovs-openflowd dp0 tcp:192.168.0.1 --out-of-band
Aug 16 15:28:57|00001|openflowd|INFO|Open vSwitch version 1.0.1
Aug 16 15:28:57|00002|openflowd|INFO|OpenFlow protocol version 0x01
Aug 16 15:28:57|00003|ofproto|INFO|using datapath ID 0000002320b3af5c
Aug 16 15:28:57|00004|rconn|INFO|tcp:192.168.0.1: connecting...
Aug 16 15:28:57|00005|netdev|WARN|attempted to create a device that 
may not be created: eth2
Aug 16 15:28:57|00006|ofproto|WARN|ignoring port eth2 (2) because 
netdev eth2 cannot be opened (No such device)
Aug 16 15:28:57|00007|netdev|WARN|attempted to create a device that 
may not be created: eth1
Aug 16 15:28:57|00008|ofproto|WARN|ignoring port eth1 (1) because 
netdev eth1 cannot be opened (No such device)
Aug 16 15:28:57|00009|netdev|WARN|attempted to create a device that 
may not be created: dp0
Aug 16 15:28:57|00010|ofproto|WARN|ignoring port dp0 (0) because 
netdev dp0 cannot be opened (No such device)
Aug 16 15:28:57|00011|rconn|INFO|tcp:192.168.0.1: connected
Aug 16 15:28:57|00012|netdev|WARN|attempted to create a device that 
may not be created: eth2
Aug 16 15:28:57|00013|ofproto|WARN|ignoring port eth2 (2) because 
netdev eth2 cannot be opened (No such device)
Aug 16 15:28:57|00014|netdev|WARN|attempted to create a device that 
may not be created: eth1
Aug 16 15:28:57|00015|ofproto|WARN|ignoring port eth1 (1) because 
netdev eth1 cannot be opened (No such device)
Aug 16 15:28:57|00016|netdev|WARN|attempted to create a device that 
may not be created: dp0
Aug 16 15:28:57|00017|netdev|WARN|attempted to create a device that 
may not be created: eth2
Aug 16 15:28:57|00018|netdev|WARN|attempted to create a device that 
may not be created: eth1
Aug 16 15:28:57|00019|netdev|WARN|attempted to create a device that 
may not be created: dp0
Aug 16 15:28:57|00020|netdev|WARN|attempted to create a device that 
may not be created: eth2
Aug 16 15:28:57|00021|netdev|WARN|attempted to create a device that 
may not be created: eth1
Aug 16 15:28:57|00022|netdev|WARN|attempted to create a device that 
may not be created: dp0
Aug 16 15:28:58|00023|netdev|WARN|attempted to create a device that 
may not be created: eth2
Aug 16 15:28:58|00024|netdev|WARN|attempted to create a device that 
may not be created: eth1
Aug 16 15:28:58|00025|netdev|WARN|attempted to create a device that 
may not be created: dp0

Has anyone an idea what is the problem?





More information about the discuss mailing list