[ovs-discuss] Problem with a desired flow getting deleted

Jesse Gross jesse at nicira.com
Mon Feb 15 22:59:50 UTC 2010


On Mon, Feb 15, 2010 at 4:55 PM, Todd Deshane <deshantm at gmail.com> wrote:

> On Mon, Feb 15, 2010 at 3:28 PM, Jesse Gross <jesse at nicira.com> wrote:
> > Again, ovs-dpctl dump-flows is your friend.  It will show you the
> currently
> > active flows as well as the actions.  You must run it while there is
> traffic
> > on the network due to the 5 second timeout.
>
> Your previous response of internalbr and externalbr being
> pseudo-devices helped me figure out the problem I was having. My
> solution, in case others happen to run across a similar problem in the
> future, was to treat externalbr as the main connection to the Internet
> (bring it up with dhclient) and leave eth0 up, but unconfigured (eth0
> shouldn't get an IP address).
>
> My init of ovs looks like:
>
> rmmod bridge
> insmod /path/to/datapath/linux-2.6/openvswitch_mod.ko
> ifconfig eth0 up
> ovs-vswitchd --pidfile --log-file --detach -v
> /path/to/ovs-vswitchd.conf  > /dev/null 2>&1
> ifconfig -a | grep externalbr >/dev/null
> while [ $? -ne 0 ]; do
>  sleep 1
>  ifconfig -a | grep externalbr >/dev/null
> done
> dhclient externalbr > /dev/null 2>&1
>
> Is there or will there be ovs and vswtichd init scripts?


There are Debian init scripts to insert the kernel modules and start
vswitchd as well as scripts for XenServer that integrate with the normal
configuration tools.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100215/0ea3c3df/attachment-0002.html>


More information about the discuss mailing list